Webhook, OSX and tunnel


Yes,I am fairly new to n8n environment. I have a very basic question, and I have searched the forums first. I installed the OSX app for a first test. I notice that I am forced to use the n8n tunnel to recieve API calls using webhooks. How do I change that? what did I miss?

Hi @skaneby, welcome to the community :tada:

You’re not forced to use the tunnel, it’s just the default setting for the desktop app to simplify things.

If you pick any other method of running n8n, e.g. using docker, no tunnel would be opened by default.

Tnx for the quick reply, but am I correct to assume that tunnel is the only option when working with the OSX app?

I think so, but @ivov can confirm for sure whether there might be a switch to prevent the default behaviour of creating the tunnel.

if so - its ok for dev purposes. and then its not a big effort to transition to a docker environment later ?

Transitioning between environments shouldn’t be a problem at all.

n8n offers a bunch of CLI commands to help with exporting and importing your workflows so you can easily migrate from one to the other, even if they run on different machines or use different databases.

If it’s just a handful of workflows, you could also simply download them directly from the UI like so (and import them in another environment afterwards):