Webhook responds to request before completing the workflow

I am calling a webhook from an application and it is configured to send the response only after the last node is completed. However, I have noticed that the workflow is sending the response before it finishes the entire workflow. I have already tried adding a “respond to webhook” node, but I am still getting the same behavior.

After receiving the response, I tried to call a second workflow via webhook with a similar process but a different endpoint. However, I received an error 502 and the instance seemes to be unavailable for a while

  • The workflow works perfect when running manually.

Information on your n8n setup

  • n8n version: 0.210.2
  • Database you’re using (default: SQLite):**
  • Running n8n via n8n.cloud

Hi @Jean_DOE_801, it seems you have already reached out via email and I’ve just gotten back to you.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.