Webhook response time slow the first time

Hello.

We are running the latest version of n8n 1.25.1

These are our .env variables

    environment:
      DB_TYPE: $DBTYPE
      DB_POSTGRESDB_DATABASE: $DB
      DB_POSTGRESDB_HOST: $DBHOST
      DB_POSTGRESDB_PORT: $DBPORT
      DB_POSTGRESDB_USER: $DBUSER
      DB_POSTGRESDB_PASSWORD: $DBPASSWORD
      N8N_ENCRYPTION_KEY: $ENCRKEY
      N8N_BLOCK_FILE_ACCESS_TO_N8N_FILES: false
      NODE_TLS_REJECT_UNAUTHORIZED: 0
      TZ: $TIMEZONE
      DB_LOGGING_MAX_EXECUTION_TIME: 5000
      N8N_DIAGNOSTICS_ENABLED: "False"
      N8N_USER_MANAGEMENT_DISABLED: "False"
      N8N_TEMPLATES_ENABLED: "False"
      #N8N_USE_DEPRECATED_REQUEST_LIB: 'true'
      #N8N_LOG_LEVEL: verbose
      N8N_PERSONALIZATION_ENABLED: "False"
      N8N_VERSION_NOTIFICATIONS_ENABLED: "False"
      N8N_DIAGNOSTICS_CONFIG_FRONTEND: ""
      N8N_DIAGNOSTICS_CONFIG_BACKEND: ""
      EXTERNAL_FRONTEND_HOOKS_URLS: ""

We have a very simple workflow with a webhook

We activate this workflow and we try to get the data with time curl https://...... | jq command.

Everything works fine BUT the first time it takes 5 seconds and if i hit curl again it is near instant

The first time

  },
  {
    "uid": "668d5b07-92e3-4d54-a0ce-525bcf1a42f3",
    "email": "[email protected]",
    "firstname": "Tommy",
    "lastname": "Paucek",
    "password": "37$rEZvx"
  }
]

real    0m5,211s
user    0m0,096s
sys     0m0,020s

The second time

,
  {
    "uid": "55333d4d-ab33-4351-8943-41c43057269f",
    "email": "[email protected]",
    "firstname": "Leonard",
    "lastname": "Lemke",
    "password": "q_4lkQnd"
  }
]

real    0m0,125s
user    0m0,068s
sys     0m0,019s

BUT if you wait 1 minute and hit curl again. It takes 5 seconds again. With the second curl it goes again near instant.

I thought adding EXECUTIONS_PROCESS = main but you said is deprecated.

How can i have contantly fast response times no matter how many minutes hours passed without doing the first curl?

To summarize.

1st curl → 5 seconds response
Next curls before letting 1 minute to pass → near instant response
Next curl after 1 minute give or take have passed from the 1st curl → 5 seconds response again

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Please excuse me.

It was an internal network problem with a specific firewall rule policy that had a low TTL between 2 VLANs.

1 Like

Hey @Mulen,

That would do it, Thanks for letting us know.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.