Wekan issues with Author ID

Hi everyone,

right now I’m trying to enable mails to create new cards in Wekan. However, while trying to enable n8n to use Wekan, I can select all the options with my credentials. However, there is no Dropdown for “Author ID”.

This is the issue that comes up:

Issues:

  • There was a problem loading the parameter options from server: “users is not iterable”

Any ideas on that?

@Nevarro Welcome to the community.

The only thing I can think of it’s that the credentials are not correct. If you do for example a board:create, does it work? If not then the credentials might the issue.

Thanks for getting back to me. With board:create “Owner” shows the same error. However, I can choose all the other fields correctly, so the credentials should be right.

What do you mean with you can choose the other fields correctly? the other fields within board:create? if so, then it does not prove the credentials are working as those fields are not loaded.

For example with card:create I can choose Board ID, List ID, Swimlane ID and it’s not a public board.

Ah, I see. The credentials are working then. What about the user you are using in the credentials? Does it have ‘admin’ permissions? Perhaps, it’s a permissions issue. If this is not the issue, the only think I can think of it’s that we are using an older version of the Wekan API.

In any case, the fields that do not load you can set them manually via expressions.

1 Like

Thank you. Giving the user admin rights was the solution.

Glad the it worked. Let us know if you have any other questions.