What do I set the webhook url to?

Describe the issue/error/question

I dont understand what to set the webhook url to. Is it my public ip? Im running it on another computer in my house (raspberry pi) and any and all links it asks me to copy for clickup all say local host. Like oauth2 and webhook test link. Im not receiving any events for my click up trigger when it is set to * i assume thats do to the webhook uri being set to local host. So what do I do to fix it? Set it to my public url?

What is the error message (if any)?

Uri mismatch

Please share the workflow

(Select the nodes and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow respectively)

Share the output returned by the last node

Information on your n8n setup

  • n8n version:
  • Database you’re using (default: SQLite):
  • Running n8n with the execution process [own(default), main]:
  • Running n8n via [Docker, npm, n8n.cloud, desktop app]:
    npm n8n raspberrypi
1 Like

Hi @Stifling1488

Welcome to the n8n community :tada:

Since you have mentioned you’re running in local you need a tunnel to let n8n communicate with the outside world and I see that you’re using n8n with npm

So you have to start the n8n with the --tunnel flag

It’ll give a URL that you can paste into the service like ClickUp or something.

n8n start --tunnel

You can refer to the below documentation for more information.


Please note that this service n8n provides for free of cost.
This is only for Testing purposes, Not for production usage. Because the URL may get changed anytime.

1 Like

Thank you but I was hoping to just use my ip for the time being since I dont want to have to set back up the connections anytime the tunnel changes

1 Like

Is that the only way?

1 Like

You’re missing out few steps in that case.

You can’t directly use your ISP Static IP Address. You need port forwarding and lot more stuff.

I suggest you to look at this thread.

Alternative you can get a VPS from Hetzner (Cheap and Best - Using it for 2 years) or any cloud provider and run n8n instance there. You can use a domain or subdomain for this. No tunnel needed in this case.

Also, you can use https://n8n.cloud


Thanks so much this exactly what I was looking for! Youre amazing you have no idea how much I appreciate you!

1 Like

Happy to help! Enjoy :tada: