When setting query value manually and field is empty output becomes NaN

Describe the issue/error/question

When changing the value of a field using value prop, and the filed is empty, NaN is sent but I want it to be absent
If I remove value: '={{...}} part and set the filed to empty, It will not appear in the output

How can I suppress output when field is empty using this formula?

Please share the workflow

	displayName: 'Expire Date From',
	name: 'expireDateFrom',
	type: 'dateTime',
	default: '',
	description: 'Returns customers that their service expire time is newer than given time',
	routing: {
		send: {
			property: 'expireDateFrom',
			value: '={{DateTime.fromISO($parameter["expireDateFrom"]).toMillis()}}',
	displayOptions: { show: { enableExpireDateFilter: [true] } },

Share the output returned by the last node


Information on your n8n setup

  • n8n version: 0.209.4
  • Database you’re using (default: SQLite): SQLite
  • Running n8n with the execution process [own(default), main]: own
  • Running n8n via [Docker, npm, n8n.cloud, desktop app]: n8n

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.