Which "Response Format" should I set it for? Learning Http_request from Course Level 1

Hello All n8n

Just learn the coure of 1. Getting Data From the Data Warehouse, following the course instruction , the correct result must show as below …

this pic show the reponse format shoud set to JSON. but when I set it to JSON, it give me a error " ERROR: Response body is not valid JSON. Change “Response Format” to “String”

2021/12/6 11:33:28

Data below may contain sensitive information. Proceed with caution when sharing.




NodeOperationError: Response body is not valid JSON. Change "Response Format" to "String"
    at Object.execute (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/HttpRequest/HttpRequest.node.js:945:35)
    at processTicksAndRejections (internal/process/task_queues.js:93:5)
    at async /usr/local/lib/node_modules/n8n/node_modules/n8n-core/dist/src/WorkflowExecute.js:447:47

I check all the setting again and again , if i set the reponse format to string , it works but get the result not the same like the coure instruction , below is the result when i set it to string…

what is the proplem , I coudn’t find it…

waiting your help, thanks in advance!!

Hey @makechinafreedom,

For your URL are you sure you are using https://internal.users.n8n.cloud/webhook/custom-erp and not something else?

the url I get for the email when I join the coure. here it is n8n Course Redirect

It should be the URL mentioned in the training not the one in the email, Try using the other URL and you should be all good.

In the left panel, select:

    Authentication: Header Auth
    URL: https://internal.users.n8n.cloud/webhook/custom-erp
    Options > Add Option > Split Into Items: toggle to true. This option will output each element of an array as its own item.
    Headers > Add Header:
        Name: unique_id
        Value: your_unique_id
1 Like

Thanks I try to test.


1 Like

thanks, Jon, I move to next step Inserting Data into Airtable…


Perfect, Good luck with the rest of the course :+1:

1 Like

all finished thank you @jon

1 Like