Why i can't activate my webhook trigger node?

Describe the problem/error/question

My webhook trigger node doesn’t run even i do not use any other node.

What is the error message (if any)?

ERROR: Cannot read properties of undefined (reading ‘getNodeParameter’)

Please share your workflow

I can’t share my workflow, it required upgrade plan
(Select the nodes on your canvas and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow.)

Share the output returned by the last node

Information on your n8n setup

  • version: 1.31.2
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
    npm
  • Operating system:

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

if you are running with the test version you need to activate it first before using it

How could I know if my version is a test version and how can I activate it? I use my company workflow so I don’t have much information about this.

Toggle between the test and production url.
You can use the test to see how the workflow is going or the production state on an active workflow

I just use GET method and it even not start


When using a “webhook-test” you MUST click on test the workdflow and have the nod eliten for an event. You can then test on postman

If you are running it ona production environment, just actiaate the workflow and it will listen

I have run it in my localhost and it works, but when I change it to run in my company workflow it won’t start and says there is an error in the code, I have checked it and found out error in this line
canNotGetNodeParamenter
it said that it could not get the “options”