Woocommerce Flow not working


Hi we were trying to run Woocommerce nodes on our hosted instance.
We tried with both the API node & the webhook node. But the node isnt getting executed. Its just showing ‘executing’…
Can you debug this? We believe the credentials we used are fine. and to test out the webhook, we placed a test order and executed the workflow.
(to test the API we simply tried to GET all orders and even that didnt work)

Hi @Saandhy_Ganeriwala1, I’m sorry to hear you’re having trouble here. The screenshot shows the regular WooCommerce node rather than the respective Trigger. Would you be able to share the full workflow JSON (without anything confidential in it, of course) and also a screenshot of the entire workflow execution on your end showing where the flow gets stuck?

Many thanks!

Hi @MutedJam please have a look at this video. I have tried to explain:

Hi @Saandhy_Ganeriwala1, many thanks for sharing the video (make sure you invalidate any key and secret shared in it though as it’s publicly visible).

What happens when clicking “Execute Node” on the trigger node is that n8n first registers a new webhook and then waits for this webhook to arrive.

This would also happen on the regular (non-trigger) WooCommerce node though if an active Trigger node is present in the workflow. So for the regular node to work you would want to disable/delete the Trigger node.

Hi @MutedJam i deleted the other node and tried executing the regular node. but it still didnt work. any suggestions?

So you have a workflow consisting of the WooCommerce node only (not the trigger) and are still seeing only the loading screen when executing the node? No error?

This would suggest WooCommerce can’t be reached from your instance. Is there maybe some firewall/proxy or anything else in your network blocking communication?