Woocommerce Trigger - order.created: How can I make it trigger with 100% consistency?

Hi all,
I’m testing the Woocommerce Trigger with order.created but it does not trigger with consistency when I create an order.
Can you please advice me how to make it 100% consistent and reliable ?

API Rest was set and working
n8n version is 0.218.0
Server on Hetzner VCPU: 2 and RAM: 2GB

Thank you !


Hey @william,

How do you have n8n installed is it npm / docker or something else? If you check in WooCommerce is it using the webhook url or webhook-test and does it show any errors?

Hi Jon,
Happy to answer your questions:
Installed with Docker (following your user guide).
Using webhook URL (its created by the n8n Woo Trigger module with OAuth2)

By the way let me congratulate your team for producing great documents, really impressed by the high quality (screen shots,…).

1 Like

Hi @Jon, I think I understood better your question now.
I notice the following difference in behaviour between “Editors (listening)” mode and “Productions” mode.

The Woo Triggering issue seems to be on the “Editors” mode. Although it’s well in listening mode, it does not trigger. The logbook on Woocommerce shows a correct Delivery ID but the response array sometimes shows code 404 and message Not Found.

In the webhook URL generated by n8n, I can see webhook instead of webhook-test

Hope this can help in the analysis.

Another remark for Editors mode:
Sometimes, the n8n web display does not show a trigger but the backend has triggered correctly.
This can be misleading and give the impression of no consistent trigger in Editors mode.

A 404 is unusual but if the webhook in Woo does show webhook-test it would only work when you press execute workflow and only the once. If you activate the workflow in n8n then enable the execution logging for the workflow it would be interesting to see if the workflow actually errors.

Is Woo installed on the same server or somewhere else?

Woo and n8n are installed in different locations

It could be that n8n is restarting for some reason and that is why the url is showing as a 404, I would start with the execution logging and maybe checking the docker log to see if there are any errors reported.

Ok @Jon thanks !

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.