Wordpress Blog Domain Not Recognized

Hello, It seems that my Wordpress Blog domain is not being recognized, but I tested it with other tools (for example, Postman) and creating a post worked.

Running n8n cloud.

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:
1 Like

======
Running n8n cloud

Hey @cardo,

Welcome to the community :raised_hands:

Can you try without the /wp-json and let me know if that works?

Hello! Thanks.

I also tried without wp-json and it didn’t work.

I’m doing a test now, I suspect it’s not being recognized because the domain doesn’t have an ‘A’ entry configured, but it has the ‘CNAME’ configured and the blog and other tools access it normally.

I’m going for this alternative.

I was unable to add the ''A" entry in this domain, as the CNAME is already configured and did not leave it.

But I created and tested it with another subdomain with the entry ''A" and it recognized it, but I cannot configure 2 subdomains in the Wordpress settings.

Wouldn’t it be a bug to MUST have an A entry in the domain? Other tools, like Postman, access it and I can post normally via API.

Hey @cardo,

It should work with a cname, As a quick test I have set up your url without a username and password and I am able to get your posts.

I think the issue could be with the credential, Although if you ignore the error and try to use the node does it work anyway?

Hy @Jon

For me it still doesn’t work.
I noticed that in the WordPress login configuration, credentials are not validated, only the connection.

I tried ignoring the error and it didn’t work either.


And look how strange!

I tried directly configuring the HTTP Request and it worked.
It shouldn’t be like this, but it’s the workaround that will work for me now.

Here is the error when running, in case it helps.

That is most odd, To me it looks like both nodes are trying to do the same thing. For creating a post we use /wp-json/wp/v2/post.

I am also able to connect to your site and fetch the posts and for testing the credential we call /wp-json/wp/v2/users. I have no idea at the moment why this is not always working, Out of interest in the http request can you add a header of User-Agent and set the value to n8n and see if it still works? I have seen issues with some hosting companies where they block some user agent strings although if this was the case I would have expected my get to have failed from cloud as well :thinking: