"Workflow has been canceled or timed out!"

I’m running n8n on my own server and I keep getting this message.

image


It seems to be occurring between the wait after nimble and the split batch. In this instance after 18 iterations.

I’m running a lightsail instance with this config.
image

Is there a specific server setting to avoid this?

Hey @datdudejibril,

How long is it taking before it shows that message? Why are there so many waits as well are they all needed.

On the left of n8n if you got to workflows > Settings there is an option for timeouts where you can tweak it per workflow.

Hi Jon. I’m still running into this issue. Here’s a video of the issue. The waits are so I can visually track the path of the workflow.

https://drive.google.com/file/d/1-84WvMif-1awNy4KoFZJFN42QeQ6i4_Z/view

Hey there,

Do you happen to have a timeout set for the workflow under the settings?

The timeout defines how long the whole workflow can run in total (not how long a node can run). Meaning you currently tell n8n to kill it after 2 minutes which it seems to be doing. I would assume that if you remove the timeout, it would not do that anymore.

Do not understand what you mean with “the maximum I can set it to is 2 minutes”. Why can you not set it to a longer time?

1 Like

Ah, thanks for the clarification. I’ll remove the timeout. I’m self hosted so I guess I’d have to change the timeout settings in the server.

1 Like

You got it buddy.