Workflow is unable to detect "Set" > "Content" value

Describe the issue/error/question

Workflow is unable to detect “Set” > “Content” value.

What is the error message (if any)?

Error message is simply [not found]

Please share the workflow

Share the output returned by the last node

Outputs the ID & Hashtag column data correctly, but does not populate the Content column at all.

Information on your n8n setup

  • n8n version: Latest, downloaded today.
  • Database you’re using (default: SQLite):
  • Running n8n with the execution process [own(default), main]:
  • Running n8n via [Docker, npm,, desktop app]: Desktop app.

Hey @watanabei,

Welcome to the community :tada:

When you say it is unable to detect set > content value what do you mean? Looking at the flow you are using the node name of HTTP Request1 but the HTTP Request node is called HTTP Request so it could just be that… Another option as the Set is after the request node would be to just use {{$json["choices"][0]["text"]}}

I was referencing this guide to test the setup.

The OpenAI API works as the “text” get generated and can be seen in json, but Set is not detecting the “text” field.

Here is my screenshot for the configuration in Set.

Hi @watanabei,

The HTTP Request node is not called HTTP Request1 in your workflow so you would need to change the name or instead try using {{$json["choices"][0]["text"]}}

Set works now, ID and Hashtag gets pushed to Airtable, but the Content still doesn’t work.

Any idea why?

Screenshot here.

I can’t see anything that would be stopping it from working, What datatype is set for the Content field in Airtable?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.