Workflow just ending

Describe the problem/error/question

I am generating characters by using the Code node. It outputs ~18.000 Characters which I then want to use to request a http rest api. Parts of the response are then saved in my database. The whole execution runs without any errors, but only for 75 items. Why is that? The execution is done after 2 minutes while in reality it should definitely take longer. There is not timeout set for the workflow. Its weird because it is just finishing, while it is not even done (discord webhook not sent)

What is the error message (if any)?


Please share your workflow

The endpoints are private and therefore I cant use the exported data here.

Share the output returned by the last node

Information on your n8n setup

  • n8n version: 1.1.1
  • Database (default: SQLite): Postgres
  • n8n EXECUTIONS_PROCESS setting (default: own, main): own
  • Running n8n via (Docker, npm, n8n cloud, desktop app): docker
  • Operating system: Ubuntu 22.04

I fixed it. The problem was, that at some point the http returned no data so the workflow stopped. Changing the settings in the http node to “always output data” worked :slight_smile:


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.