Workflows not active, even thought in n8n UI they are active

Describe the problem/error/question

What is the error message (if any)?

Please share your workflow

(Select the nodes on your canvas and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow.)

Share the output returned by the last node

Information on your n8n setup

  • **n8n version: 1.3.1
  • **Database (default: SQLite):postgresql
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • **Operating system: linux

hello, n8n!
i recently faced a bug where i restarted my n8n and n8n-worker deployments in k8s and when my airflow DAGS were calling n8n i saw the error raise HTTPError(http_error_msg, response=self)
requests.exceptions.HTTPError: 404 Client Error: Not Found for url: n8n…com.

it suggested to check if n8n workflow are activated. they were activated in UI. i was trying to debug for quite some time, and eventually i just turned off and turned back on the workflows again and it did work.

is it known issue? how to prevent this from happening?

Hi @Nargiza_Fernandez, I am very sorry you are having trouble.

This does not ring any bells and I was not able to reproduce this problem on the current latest 1.22.6 and recent versions of n8n 1.24.0. Are you still seeing this after upgrading from your currentl version 1.3.1?

If so, is there a chance you have updated the workflow status in the db directly? n8n instances would only read the workflow status when launching, meaning any updates made to the db directly would not be reflected until you restart them.