Hello! Newbie here, but having a good time with n8n.
Having a little challenge with the Zendesk Connector, and pulling data from the Tickets → Get All function.
It works fine for up to 100 items, however once you set it to “return all” it fails with the below error:
ERROR: Your request is invalid or could not be processed by the service
expanding the error shows the below:
{
"message": "422 - {"error":"invalid","description":"Invalid search: Requested response size was greater than Search Response Limits"}",
"name": "Error",
"stack": "Error: Request failed with status code 422 at createError (/usr/local/lib/node_modules/n8n/node_modules/axios/lib/core/createError.js:16:15) at settle (/usr/local/lib/node_modules/n8n/node_modules/axios/lib/core/settle.js:17:12) at IncomingMessage.handleStreamEnd (/usr/local/lib/node_modules/n8n/node_modules/axios/lib/adapters/http.js:269:11) at IncomingMessage.emit (node:events:538:35) at endReadableNT (node:internal/streams/readable:1345:12) at processTicksAndRejections (node:internal/process/task_queues:83:21)"
}
The other functions such as getting users and organizations can go far in excess of 100 (ive copied out over 50K users)
Also, something else that might be of interest, Zendesk API supports sideloading of queries, to reduce API calls - see: Side-Loading | Zendesk Developer Docs
- n8n version:0.170.0
- Running n8n via Docker (have also tested on desktop app)
Thanks!
