Zendesk Target disappears after sometime

Hey guys

I created a workflow using Zendesk Trigger. It works fine for some time (~1h) and then the target is simply removed. It was not the “test” target but the live one.

This is already set:

I am not using the n8n UI but by calling the Node backend directly.

I was wondering why and when the targets are removed as probably this is my fault :slight_smile: . Should I set some flag somewhere?


Hi @victorpantoja, I’m sorry to hear you are having trouble. Can you confirm where and how exactly you are checking your targets? The n8n webhooks registered by the Zendesk Trigger node show up as triggers for me in Zendesk, so I am unfortunately not 100% sure I understand the problem:

Many thanks!

Exactly as you wrote.

As I am not using the UI, I am probably wrongly assuming something.

Right after adding the node via my API, it works (that is, the target appears). Then, it disappears as it was programmed to do so.

This might be related: sometimes, the webhook path is like <uuid>/webhook, sometimes like <workflow_id>/webhook

So my triggers created by n8n yesterday are still in place and the webhooks are still being sent. I am not sure which API exactly you are using and how though. Could you describe the steps to reproduce what you are doing on your end?

And are you using tunnel URLs/any other temporary URLs by any chance? I am wondering if Zendesk might automatically remove webhook destinations if it fails to send a webhook n times in a row or something.

Hey, @MutedJam ! Sorry about this late reply.

The way this node works using n8n UI is:

  1. User adds the Zendesk trigger (target is not yet created on Zendesk)
  2. User executes the node: a test target is created on Zendesk (ex. /webhook-test/35b0557d-b752-4ff0-ab10-c2605881e97a/webhook)
  3. User cancels the execution: the test target is removed
  4. User activates the workflow: a target like /webhook/35b0557d-b752-4ff0-ab10-c2605881e97a/webhook is created. Sometimes, this path is “127/zendesk trigger/webhook”. (why?)
  5. User clicks on “Execute workflow”. The test target is created again (ex. /webhook-test/35b0557d-b752-4ff0-ab10-c2605881e97a/webhook).
  6. User stops the execution: the test target is removed and only the “live” target remains.

As I wrote, I am not using the n8n UI. I created a very simple python client to deal with the NodeJS backend. This API is just getting and posting data as the UI does. This is how the API adds a node:

  1. API get all available nodes and there parameters
  2. our frontend display this options and sends a post to our API
  3. our API sends a PATCH to the NodeJS backend and adds the node to the workflow (so far, no target was created on Zendesk)
  4. Our user activates the workflow: our API updates n8n workflow and activate it. Now, I target is created on Zendesk. This is the target that vanishes after a couple of hours.

Our use case is different from others as we don’t use the n8n UI. I am afraid that I missed something here and that’s why I wanted to understand a bit more the internal details of this node.


Hi @victorpantoja, can you share the exact API requests which you are making that lead to the creation of a trigger in Zendesk which disappears after a couple of hours?

As mentioned, n8n doesn’t behave in the way you have described for me so at this stage I am still struggling to reproduce the problem. n8n deletes Zendesk triggers only if they are related to the current trigger node (here’s the relevant source).

Hi @MutedJam

It seems I managed to fix the “issue”. At least, the target is there since weeks now.

The problem was related to the way I was dealing with workflow deactivation on my side: once one node gets removed, I disable the workflow (our workflows must have 3 nodes to be active). At this point, the target disappears. When the user adds the node again and re-activates the workflow, I was not really activating the n8n workflow properly and the target was not being re-added.

I will keep an eye on it, just in case.

Thanks for your help and sorry the late reply!

1 Like

Awesome, glad to hear you figured it out and thanks so much for sharing!