403 when trying to post new topic in this forum

Hi,

I’m trying to post my question related to the n8 ssh module on this forum (in this category), but every time I try I get 403 message…
What could be the problem? Am I using some words that are not allowed?:
Print screen below (I tried many time create a new topic):

Thanks
Jacek

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hi @ofc_edu, can you share the full error error response you are getting?

I suspect this might get blocked by Cloudflare, but @mieky from our cloud engineering team can hopefully sort this out if you share the full error (and specifically the ray ID which should be part of the error).

As for the actual error, is there a chance you are simply using the wrong port? Their SSH service uses port 23 instead of the standard port 22 (which is used for more limited SSH functionality aimed at SFTP clients from my understanding).

1 Like

Regarding the error, it was only modular window with only “403”, without any details or text. I have not checked in browser console for more details. Regardless - I’ve checked right now and I could post the same post without any problems, so probably some kind of CloudFlare quirk.

Regards StorageBox/Hetzner - “The Storage Box provides an extended SSH service on port 23. With this service, you can use rsync, BorgBackup, and some additional command line tools.”
https://docs.hetzner.com/robot/storage-box/access/access-ssh-rsync-borg/

So problem is somewhere between restriction of storagebox shell and n8n implementation of ssh.
As I mentioned, I have no problem executing allowed commands (like “tree”) using MAKE.com ssh module, but I wanted to migrate to n8n :slight_smile:

Best regards
Jacek

trying to execute command “ls” to storagebox at port 22, returns
(please keep in mind, that connection test is sucessful)

Error: Unable to exec
    at /usr/local/lib/node_modules/n8n/node_modules/ssh2/lib/client.js:1836:39
    at CHANNEL_FAILURE (/usr/local/lib/node_modules/n8n/node_modules/ssh2/lib/client.js:661:39)
    at 100 (/usr/local/lib/node_modules/n8n/node_modules/ssh2/lib/protocol/handlers.misc.js:1283:16)
    at Protocol.onPayload (/usr/local/lib/node_modules/n8n/node_modules/ssh2/lib/protocol/Protocol.js:2059:10)
    at GenericDecipherNative.decrypt (/usr/local/lib/node_modules/n8n/node_modules/ssh2/lib/protocol/crypto.js:1269:26)
    at Protocol.parsePacket [as _parse] (/usr/local/lib/node_modules/n8n/node_modules/ssh2/lib/protocol/Protocol.js:2028:25)
    at Protocol.parse (/usr/local/lib/node_modules/n8n/node_modules/ssh2/lib/protocol/Protocol.js:313:16)
    at Socket.<anonymous> (/usr/local/lib/node_modules/n8n/node_modules/ssh2/lib/client.js:775:21)
    at Socket.emit (node:events:517:28)
    at Socket.emit (node:domain:489:12)

Trying the same at port 23:


[
{
"code": 
8,
"signal": 
null,
"stdout": 
"Command not found. Use 'help' to get a list of available commands.",
"stderr": 
""
}
]