A problem with redis node

hello!

i think there is a bug on the redis node. when using Hash

i was setting some test hash field

image

according to the redis documents, this should insert 4 values inside. “aa” “bb” “cc” and “dd”

but actually, this is how it was inserted:

the problem is not when getting the data, the problem is when settings the data.
i checked the redis server directly, and it was even stranger, the keys and the values got mixed inside, not just the values:

image

the right way to insert hash, is like this:

image

i think the redis node does not insert the hmset in the right way. its separating each letter, instead of using “space” as the separator

1 Like

Morning,

I think this is down to where there is no field name option so the value is being looped and each character is being inserted as the field name and value.

A quick fix might be to remove that loop but that won’t support multiple values and the field name would still need to be set somewhere.

the separator for each value should be a space, like the last screenshot i put

Can you not have a value with a space in it or would you need to wrap them in quotation marks?

no need value as a space. there is no use case for that

1 Like

Hey @koraal,

If you get a chance could you check the pull request below, I suspect it will do what you are after but it will need some proper testing.

2 Likes

Let me know when you confirm that what @jon added fixes the issue to review the PR.

1 Like

solution works. you can merge it in

This will be a breaking change for anyone using the Redis node with the hash option as the field name now has to be set in the value. The node now works the same way as the redis command line tool does.