About testing my nodes

I want to test my custom node and I’m using this docs Tutorial: Build a programmatic-style node | n8n Docs
but when I run “npm link” it has this errors

npm WARN cli npm v10.4.0 does not support Node.js v18.12.0. This version of npm supports the following node versions: ^18.17.0 || >=20.5.0. You can find the latest version at https://nodejs.org/.
npm ERR! code EPERM
npm ERR! syscall symlink
npm ERR! path C:\Users\amir\Desktop\n8n-nodes-bale-messenger-master
npm ERR! dest C:\Program Files\nodejs\node_modules\n8n-nodes-bale-messenger
npm ERR! errno -4048
npm ERR! Error: EPERM: operation not permitted, symlink ‘C:\Users\amir\Desktop\n8n-nodes-bale-messenger-master’ → ‘C:\Program Files\nodejs\node_modules\n8n-nodes-bale-messenger’
npm ERR! [Error: EPERM: operation not permitted, symlink ‘C:\Users\amir\Desktop\n8n-nodes-bale-messenger-master’ → ‘C:\Program Files\nodejs\node_modules\n8n-nodes-bale-messenger’] {
npm ERR! errno: -4048,
npm ERR! code: ‘EPERM’,
npm ERR! syscall: ‘symlink’,
npm ERR! path: ‘C:\Users\amir\Desktop\n8n-nodes-bale-messenger-master’,
npm ERR! dest: ‘C:\Program Files\nodejs\node_modules\n8n-nodes-bale-messenger’
npm ERR! }
npm ERR!
npm ERR! The operation was rejected by your operating system.
npm ERR! It’s possible that the file was already in use (by a text editor or antivirus),
npm ERR! or that you lack permissions to access it.
npm ERR!
npm ERR! If you believe this might be a permissions issue, please double-check the
npm ERR! permissions of the file and its containing directories, or try running
npm ERR! the command again as root/Administrator.

npm ERR! A complete log of this run can be found in: C:\Users\amir\AppData\Local\npm-cache_logs\2024-03-31T13_51_41_190Z-debug-0.log

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hi @amir!

Welcome to the community :wave:

The main issue seems to be that the versions of npm and node.js that you are working with are not compatible. Have you tried updating them?

Happy building!

1 Like