Activecampaign node is not loading all tags

Hi. I have many tags on my ActiveCampaign account, but the ActiveCampaign node on N8N is not loading all of them.

I attempted to reload the list of tags, but the same tags continue to appear.

What steps should I take to load all my tags from ActiveCampaign?

  • n8n version: 1.18.2
  • n8n cloud
  • Operating system: Windows 10

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:
  • n8n version: 1.18.2
  • n8n cloud
  • Operating system: Windows 10

Hey @douglasdavidmelo,

Is this failing when using Tags > Get All or when trying to select a Tag under Contact Tag > Add?

Hi Jon.

Under Contact Tag > Add

Hey @douglasdavidmelo,

Perfect thanks, I have put in the PR below which fixes this. Once reviewed it will be merged and available in a future release. Possibly 1.22.0 next week as we may have missed the 1.21.0 release for this week.

Thank you.

So, I just need to wait for the new release and update N8N to version 1.22.0, correct?

Is there any temporary manual solution until then? Can I add the ActiveCampaign tag by its number?

Hey @douglasdavidmelo,

You got it, So once 1.22.0 is released you would need to upgrade sadly we misssed this weeks release by 10 minutes.

As a manual solution if you know the ID for your tag you can change the field to an expression and use that instead.

Thank you Jon.

1 Like

New version [email protected] got released which includes the GitHub PR 8017.