After update n8n is not picking up SQLite database

Describe the problem/error/question

After updating n8n to a new version - n8n was completely blank and asking to create user. Data was stored locally (not in a docker), I’ve checked the path and I’ve seen my SQLite databse and everything in it was intact. The configuration of the docker container was not changed - paths are exactly the same. I’ve checked the .n8n folder in docker and looks like it is just not picking up local folder.

What is the error message (if any)?

n8n is completely blank after docker update

Information on your n8n setup

  • ver 1.4.1
  • SQLite
  • Running via docker
  • Unraid

Hey @Oleg_Budeanu,

Welcome to the community :tada:

Can you check the user the container is running as and what data path it is using? Some systems that provide a UI around docker use the root user instead of the Node user and that can cause issues.

1 Like

Hi Jon,
Thanks for such a fast reply! So I could not access the “root” inside the docker when I tried. What I’ve done is I deleted the container and installed it from fresh and it worked - now it’s migrating the existing database. Weird that after updating it did not work properly.

1 Like

It is a bit odd, I wondered if maybe you went from a pre v1 to v1 which can cause it depending on the configuration.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.