Allow to use Google service account credential in HTTP request node

Yes, that’s what this option does.

As for the error you mention, make sure to keep the private key format as is and you shouldn’t have any errors.


I’m getting the same error as @tkey, but defining the private key in Salesforce JWT API Credentials.

There was a problem loading the parameter options from server: "secretOrPrivateKey must be an asymmetric key when using RS256"

I tried to put the private key in different ways, with \n and without \n, with and without the private key header and footer file, but the error message persisted.

I generated key and certificate following this tutorial here.