Any idea why the SMTP mailer would error on SSL?

Describe the issue/error/question

I received this error after moving a Email node from one instance to another. They are configured the same.

What is the error message (if any)?

Error: C0972104817F0000:error:0A00010B:SSL routines:ssl3_get_record:wrong version number:../deps/openssl/openssl/ssl/record/ssl3_record.c:355:

Please share the workflow

Share the output returned by the last node

Information on your n8n setup

  • n8n version: 0.208.1
  • Database you’re using (default: SQLite): MySQL
  • Running n8n with the execution process [own(default), main]: own
  • Running n8n via [Docker, npm,, desktop app]: npm

Hi @cgsmith, this would happen if your SMTP server uses STARTTLS instead of SSL. An indicator for this is often a port other than 465, and SSL/TLS toggle would need to be off for STARTTLS.

SSL should still work though, I’ve just tested the below config and the email went out as expected:

Perhaps you can confirm which provider you are using?

Ok - I changed to 465 and it gave the error below. I am using PostmarkApp if it matters.

Error: Connection timeout
    at SMTPConnection._formatError (/root/.nvm/versions/node/v18.12.1/lib/node_modules/n8n/node_modules/nodemailer/lib/smtp-connection/index.js:790:19)
    at SMTPConnection._onError (/root/.nvm/versions/node/v18.12.1/lib/node_modules/n8n/node_modules/nodemailer/lib/smtp-connection/index.js:776:20)
    at Timeout.<anonymous> (/root/.nvm/versions/node/v18.12.1/lib/node_modules/n8n/node_modules/nodemailer/lib/smtp-connection/index.js:235:22)
    at listOnTimeout (node:internal/timers:564:17)
    at processTimers (node:internal/timers:507:7)

I then kept at 465 but removed SSL/TLS option and received the same timeout.

From checking their documentation at SMTP Service | Postmark you might have to use port 587 and the SSL/TLS switch set to “Off” (so n8n uses STARTTLS instead of SSL).

Thank you for checking! I didn’t catch that! Worked with 587 and SSL/TLS option off.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.