Application is showing an error "Webhook configuration already exists"

Hi! Some of our n8n workflows use ClickUp triggers to do something (for instance, “when a ClickUp ticket is created do some action…”) that cannot be modified now due to the error “Webhook configuration already exists”. This issue has been presented since three or four days ago.

To fix this, we tried removing the ClickUp webhook box and replacing it with another identical box, and it worked! The issue is that this error is being triggered every day or after some hours in all the workflows and this is a headache for all the team. We checked and nobody is duplicating the workflows or something else.

There is an image of the error:
image

Information on your n8n setup

  • n8n version: Version 0.231.2
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker

Hi @NGGGG, I am sorry you’re having trouble.

The Clickup trigger is using webhooks under the hood and the error sounds like n8n is trying to register a webhook URL that already exists.

Seeing you are running a somewhat old version of n8n and n8n has changed a bit since, can you confirm if this is still happening on the latest version of n8n for you?

You might also want to clean up your ClickUp webhooks. They do not offer a UI for this unfortunately as far as I can tell, but you can use their API’s Get Webhooks endpoint to list existing webhooks and then delete the n8n ones as needed using the Delete Webhook endpoint.

We are using n8n cloud and are running into the same issue. It happens every other time when updating a workflow, which requires us to manually delete the webhook through the API.

Hi @Martin_Bories, thanks for chipping in here!

While I could not reproduce this myself so far, it very much sounds like we don’t identify existing ClickUp webhooks as we should. I’ll ad this to our bug tracker for a closer look.

As a workaround until this is fixed, perhaps you want to consider using the regular webhook node instead of the ClickUp trigger? This would mean n8n no longer tries to manage webhooks for you, avoiding this problem. On the downside you would have to manually add the webhook URL to ClickUp through their API

Same issue here with Version 1.18.2

I created a workaround workflow to quickly delete all webhooks in clickup from n8n, deactivating all workflows and activating them again, so that the error is resolved.

In order to only (de)activate the n8n workflows with clickup trigger nodes, add the “clickup-webhooks” tag first to the workflows, as there’s a filter added in the 6th node for that.

1 Like

Hi ! Same problem here on version 1.24.1