Are you trying to mount a directory onto a file (or vice-versa)? Check if the specified host path exists and is the expected type

I can’t finish installing the N8N on the digital Ocean, I’ve already deleted some droplets to start again and have the same result.

The following error:

Error response from daemon: failed to create task for container: failed to create shim task: OCI runtime create failed: runc create failed: unable to start container process: error during container init: error mounting “//n8n- docker-caddy/caddy_config/Caddyfile” to rootfs at “/etc/caddy/Caddyfile”: mount //n8n-docker-caddy/caddy_config/Caddyfile:/etc/caddy/Caddyfile (via /proc/self /fd/6), flags: 0x5000: not a directory: unknown: Are you trying to mount a directory onto a file (or vice versa)? Check if the specified host path exists and is the expected type

[n8nuser  n8nuser  4.0K]  .
├── [n8nuser  n8nuser  1.1K]  LICENSE
├── [n8nuser  n8nuser   779]  README.md
├── [n8nuser  n8nuser  4.0K]  caddy_config
│   └── [n8nuser  n8nuser    89]  Caddyfile
├── [n8nuser  n8nuser   782]  docker-compose.yml
└── [n8nuser  n8nuser  4.0K]  local_files


File  docker-compose.yml
  GNU nano 7.2                                                                           docker-compose.yml                                                                                     version: "3.7"

services:
  caddy:
    image: caddy:latest
    restart: unless-stopped
    ports:
      - "80:80"
      - "443:443"
    volumes:
      - caddy_data:/data
      - ${DATA_FOLDER}/caddy_config:/config
      - ${DATA_FOLDER}/caddy_config/Caddyfile:/etc/caddy/Caddyfile

  n8n:
    image: docker.n8n.io/n8nio/n8n
    restart: always
    ports:
      - 5678:5678
    environment:
      - N8N_HOST=${SUBDOMAIN}.${DOMAIN_NAME}
      - N8N_PORT=5678
      - N8N_PROTOCOL=https
      - NODE_ENV=production
      - WEBHOOK_URL=https://${SUBDOMAIN}.${DOMAIN_NAME}/
      - GENERIC_TIMEZONE=${GENERIC_TIMEZONE}
    volumes:
      - n8n_data:/home/node/.n8n
      - ${DATA_FOLDER}/local_files:/files

volumes:
  caddy_data:
    external: true
  n8n_data:
    external: true


Caddyfile

  GNU nano 7.2                                                                                Caddyfile                                                                                         n8n.xxxxxxxxxxxx.com {
    reverse_proxy n8n:5678 {
      flush_interval -1
    }
}

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hi @mmp, I am sorry you’re having trouble with your docker setup.

This looks like your Caddyfile is simply not living at //n8n-docker-caddy/caddy_config/Caddyfile. Which value did you set for DATA_FOLDER?

And can you run the pwd command on your host system in the directory in which your caddy_config folder lives to get an idea of its full path?

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.