Asana and Google Chat not coexisting

Describe the issue/error/question

For some reason we cannot put both the Asana Trigger node and the Google Chat Action node on the same workflow successfully.

If we pause the Asana Trigger node and inject some data directly to the Google Chat action it works fine.

If we pause the Google Chat action, the trigger works fine.

If both items are unpaused we get a failed execution “One or more of the used credentials are not accessible.” and in the instance of the execution it looks like no data was passed at all. This is even if there is an if fork and the data resolves on a branch that would never reach the google chat action.

What is the error message (if any)?

“One or more of the used credentials are not accessible.”

Please share the workflow

Share the output returned by the last node

Information on your n8n setup

  • n8n version: 0.189.1
  • Running n8n via hosted server:

I moved the Google Chat action to another workflow, then used an Execute Workflow action to trigger the other workflow.

If the Asana Trigger trigger is unpaused, it fails saying there is no “workflow 12”. If I pause the Asana Trigger and manually inject the information, it triggers workflow 12 just fine and everything runs fine.


I created a new workflow, copied everything from the original workflow to it without changing anything, and tried it again. It worked fine. Something must have been bugged about the original workflow.

1 Like

Hi @EricSGS, sorry for the trouble!

This sounds like it could have been a problematic migration following the introduction of user management. I am glad to hear you sorted it out, thanks so much for confirming and for sharing your workaround!