Authentication with odoo.sh failing without reason

Describe the problem/error/question

I’m able to authenticate successfully with a “hosted” Odoo account at https://odoo.com

However the real one I want to authenticate is at Odoo.sh which is their pseudo self-hosted solution where the database instance has git integration etc.

When I fill in the details for that instance, authentication fails with no detailed error log.

I’ve checked many times for typos, and tried using both the odoo password, and the api key.

My main question, is there anything about how the built-in odoo auth is functioning such that it is hard-coded to go to odoo.com’s hosted version, and won’t work with odoo.sh databases?

What is the error message (if any)?

Couldn’t connect with these settings
Credentials are not valid

Information on your n8n setup

  • n8n version: 1.15.2
  • Database : postgres 15
  • **Running n8n via Docker
  • Operating system: ubuntu 22.04 lts

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

I solved the problem. The odoo.sh database name is only visible in ONE place.
When you enter developer mode, it is in the upper right under your name.
In my case it was so long that it wasn’t visible unless I opened chrome tools to look at the text of the element. Which was the database name.

1 Like

That is a great find, thanks for sharing.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.