Authorization data is wrong! Webhooks


I am getting a wild error from the webhook element

Authorization data is wrong!

The authentication is set to none

What am I doing wrong, I am new to N8N, still figuring things out

Hi @Keep_Innovations, I am sorry you are having trouble. Can you share a workflow using which your problem can be reproduced and the exact request you are sending to your webhook URL?

How do I do this, please remember I am new. I also just replaced the webhook with a new one, seems to be ok…

Quick query, please dont ask me to open new thread. When I finish creating a workflow, I need to click execute workflow to have it up and running?

You can simply draw a rectangle around all relevant nodes on your canvas, hit Ctrl+C to copy these and then press Ctrl+V here on the forum to past them.

However, if it is now working with a new webhook you could also leave it at that.

Yes, and no.

When you click execute workflow, you can send a request to your Test URL and would see the incoming data straight away on your n8n canvas.

However, the production URL would only be available once you activate your workflow. Incoming data would be processed in the background and not show up on the canvas straight away. Provided you store execution data you can view such production data via the executions list: All executions | n8n Docs

Just a quick reply for anyone having the same issue - It seems this is a response to having the ‘ignore bots’ flag set. With that set it returns this response for anything with a user-agent set to curl. I turned off that setting and it all came back to life.
You’ll not spot that if testing in the browser, so it can hit you unexpectedly just when you though it was tested and working and you give the webhook out for someone else to use.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.