AWS Credentials Issue

Hi all, I’ve just upgraded from 0.190.0 to 0.193.5 and now for my AWS Credentials I’m getting the below error: “Couldn’t connect with these settings - UNKNOWN ERROR - check the detailed error for more information”

The full error log is below:

TypeError [ERR_INVALID_ARG_TYPE]: The "string" argument must be of type string or an instance of Buffer or ArrayBuffer. Received an instance of Object
    at new NodeError (node:internal/errors:387:5)
    at Function.byteLength (node:buffer:740:11)
    at RequestSigner.prepareRequest (C:\Users\mkay\AppData\Roaming\npm\node_modules\n8n\node_modules\aws4\aws4.js:149:44)
    at RequestSigner.sign (C:\Users\mkay\AppData\Roaming\npm\node_modules\n8n\node_modules\aws4\aws4.js:169:30)
    at aws4.sign (C:\Users\mkay\AppData\Roaming\npm\node_modules\n8n\node_modules\aws4\aws4.js:372:50)
    at Aws.authenticate (C:\Users\mkay\AppData\Roaming\npm\node_modules\n8n\node_modules\n8n-nodes-base\dist\credentials\Aws.credentials.js:338:29)
    at CredentialsHelper.authenticate (C:\Users\mkay\AppData\Roaming\npm\node_modules\n8n\dist\src\CredentialsHelper.js:32:39)
    at Object.httpRequestWithAuthentication (C:\Users\mkay\AppData\Roaming\npm\node_modules\n8n\node_modules\n8n-core\dist\src\NodeExecuteFunctions.js:821:65) {

I’ve tried doing a fresh install and creating brand new credentials but the same error is thrown. If I roll back to 0.190.0 I’m able to create the credentials with no errors thrown. Does anybody know how I can fix this?

Information on your n8n setup

  • n8n version: 0.193.5
  • Database you’re using (default: SQLite): SQLite
  • Running n8n with the execution process [own(default), main]: own
  • Running n8n via [Docker, npm,, desktop app]: npm

Hi @mkay, I am so sorry for the trouble. I thought these problems were fixed with [email protected] :frowning:

Could you share a workflow using which this problem can be reproduced?

@MutedJam I’m getting the error on a fresh install with no flows and going to Credentials > New > AWS from the main menu

Hey @mkay,

Just had a look and I was able to reproduce the issue, I have created an internal ticket which we will be tracking as N8N-4636. I will let you know when we have fixed it.

It looks like the nodes will still work it is just the credential testing that will fail.


@Jon Thank you for looking into this and finding the issue. Glad to hear the nodes will still work regardless of the testing