AWS lambda problems

I want to use the node for AWS lambda to execute my task.but i meet a problems.

how should I solve it ?

Welcome to the community.

Just tested it and it’s working just fine for me.

Why is it the function field in red? is it the server running? in which line the body is undefined?

Thanks for reply,
my aws region is cn-northwest-1 . Could that be the reason?

After I chose the Credentials,the function field change to red. It doesn’t change whether I fill in the function name or not。

There is no region called cn-northwest-1 according to this

It may just be that the document isn’t updated, but it’s real

Got it. Well I will suggest you make sure the credentials have attached a policy with access to execute a lambda function.

I confirmed it again.the credentials have attached a policy with access to execute a lambda function.Is there any other plan ?

Thanks for reply. I finally solved this problem, the core problem is the correct endpoint is ,but the source code is ${service}.${credentials.region}

ahh that is quite weird as it works for me with the current form. I wonder if this applies just for that region.

@jan the lambda endpoint url for cn-northwest-1 and cn-north-1 is endswith ,Can this compatible support be updated to the next release ?

Added it to my TODO list.

@RicardoE105 I was pleasantly surprised to find that the latest version of N8N already supports custom endpoints. I couldn’t wait to use it, but I got the following error.

I don’t know what the problem is. The Endpoint still works when I manually modify the source code in the last version

Hey @liushengyi about two weeks ago I fixed a bug with this issue here:

Should be working fine now. Have you tried it recently? I think it was fixed in version 0.101 if I am not mistaken.

It has been working,Thank you~