AWS S3 binary file upload gives error Request body larger than maxBodyLength limit

I am using AWS S3 node to upload binary data to a bucket. I am able to upload small text files. But a 10 MB csv file that is read from local as binary and re converted to binary for eventual upload to S3 using AWS S3 node. It gives error:


“message”: “Request body larger than maxBodyLength limit”,


“stack”: “Error [ERR_FR_MAX_BODY_LENGTH_EXCEEDED]: Request body larger than maxBodyLength limit at RedirectableRequest.write (/home/gowtham/n8n/node_modules/follow-redirects/index.js:102:24) at RedirectableRequest.end (/home/gowtham/n8n/node_modules/follow-redirects/index.js:127:10) at dispatchHttpRequest (/home/gowtham/n8n/node_modules/axios/lib/adapters/http.js:328:11) at new Promise () at httpAdapter (/home/gowtham/n8n/node_modules/axios/lib/adapters/http.js:46:10) at dispatchRequest (/home/gowtham/n8n/node_modules/axios/lib/core/dispatchRequest.js:53:10)”,



Hey @Gowthaman_Prabhu, I am sorry to hear you’re having trouble.

I just tried uploading a 20MB file and didn’t have any trouble:

Could you confirm which version of n8n you’re currently on and share a workflow using which the problem can be reproduced?


I am using version 0.176.0.

My Workflow:

Simple workflows with just an upload node fails too. I am only able to upload upto 4 MB…

Thanks @Gowthaman_Prabhu. I don’t have that version of n8n running anywhere at the moment I am afraid :frowning:

I do however believe this problem could have been fixed with version 0.179.0 as this version includes a bugfix for uploading large files: n8n/ at master · n8n-io/n8n · GitHub

Could you test this on your side and confirm whether the issue still persists with n8n versions after 0.179.0?

1 Like

Thank you @MutedJam. It does indeed work with version 0.179.0 :slight_smile:

P.S. I tired setting maxContent and bodyLengths at AWS S3 node level. Didn’t resolve the problem with older verisons. I see the change logs and figure I should have modified the parent nodeExecuteFunction.ts instead :smiley:

1 Like

Glad to hear this works, thx for confirming!

1 Like