AWS SNS Triggers not firing in version 0.205.0

Describe the issue/error/question

AWS SNS notifications are running in my AWS environment, but they are failing to trigger my workflow in version 0.205.0

What is the error message (if any)?

The trigger is simply not being triggered. I am currently running 0.202.1 with no issues, but it seems like most versions I update to break this node. Is anyone else experiencing this problem with version 0.205.0?

Please share the workflow

(Select the nodes and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow respectively)

Share the output returned by the last node

Information on your n8n setup

  • n8n version:
  • Database you’re using (default: SQLite):
  • Running n8n with the execution process [own(default), main]:
  • Running n8n via [Docker, npm,, desktop app]:

Hi @wumbowarrior, I am sorry to hear you’re having trouble.

I just gave the below test workflow a go on the current n8n version 0.207.1 and didn’t run into trouble here:

In a first step, could you try upgrading to the latest n8n version? If you’re still facing any issues afterwards, can you confirm whether you can see n8n’s subscription in the AWS console when your n8n workflow is active or when you’re manually executing it?

This is how the entry should look like:

I am also experiencing issues triggering SNS nodes and have tried with multiple n8n versions (0.199.0,0.207.1,0.208.0).

The subscription to the sns topics are not able to be confirmed and shows as pending in the aws console. This subscription seems to fail for both workflow activation (/webook/) and for manual execution (/webhook-test/).

So I just updated to version 0.210.2 and the issue is still there. When I trigger an SNS notification, nothing happens. Right now I am still having to work on 0.202 and I’m seven versions behind. Is there a workaround or any plan to fix this? I want to clarify that I can definitely see the SNS triggering inside AWS for this subscription. It’s just simply not responding in this version of n8n

Hey @wumbowarrior,

Looking at the history on this one it looks like we were not able to reproduce the issue and it was workign on 0.207.1.

Did you ever check the subscription status in the AWS console?

Hi Jon,

So it looks like this may be a user error on my part. Apparently when I updated versions it cleared the topic lookup method… I’m not sure if that is by design, but I did not get any kind of alert that that had happened.

Long story short, the issue is resolved. But that was really weird!


1 Like

Hey @wumbowarrior,

That is odd, I wonder if it broke when we introduced the resource locator component (the fancy dropdown).

I could see that happening. I don’t recall if it was a dropdown before, but I can confirm it is now. :slight_smile:

I am currently having this issue; but I’m running 0.213. The hook is setup, but in the AWS SNS console, the subscription is not showing confirmed. I hit request confirmation, but it asks for a URL that I don’t have; Is there a way to re-trigger this confirmation? I’m assuming that a pending confirmation in SNS will eventually time out and remove?

1 Like

Were you able to figure this out? I am facing a similar issue

Hi Rakesh_Kumar,

Jon’s comment was on the money. At some point there was an update that added a dropdown to select the topic in the SNS trigger node, and that was reset by the update. Adding it back in solved my issue. Hopefully your situation is the same!


1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.