Baserow node with single-select

Hi all,

Describe the problem/error/question

I’m using a getManyRows Baserow node. Credentials work and node returns results from the expected table. However, I cannot manage to use the filters with single-select fields. It does not look like filters are taken into account.

In this exemple above, the 33 output items are the whole table (so no filter is applied).

Do you have any suggestion on why I experience this? Do you have knowledge about this issue?

I’m using a self-hosted Docker version 1.20.0 n8n.

Thanks for your answer,
As7an

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

It looks like the first item is correct. Just set the Limit input parameter to 1 and then it will only return one value.

Try that and see if it works

Yes, the first item is correct but there are many more in the rest of results. If I set the limit to 1 I do not get all the results I want.

I tried to change the limit x, and it always returns the x first results no matter what is the field value I’m using for the test just like if the test was not taken into account.

As7an

If you share a sample of the response json shown in your screenshot I can make a code node to filter through it for you, and will add a set fields node so you can easily configure it.

I don’t have any experience with that node or service so I can’t really help with the filtering withint

Looks like a bug, I have created NODE-1111 as the internal ticket to look into why it isn’t working properly.

1 Like

@liam Yes, I already use a filter node but I guess this could be done inside the Baserow node so that the get/filtering operation can be done with only one node.

@Jon Thanks!

1 Like