Basic Webhook Worfklow doesn't stop

Describe the problem/error/question

I have a very simple workflow with a Webhook trigger that I use as health-check endpoint to call periodically so I can monitor my server’s status. I’ve recently form v 0.2?? to v 1.14.2 and replaced my MariaDB with a Postgres DB. The Webhook url and uuid is still the same as before as I backed up my flows.

What is the error message (if any)?

No message just sometimes the flow doesn’t stop:


Please share your workflow

Information on your n8n setup

  • n8n version: 1.14.2
  • Database Postgres
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via Docker on a VPS
  • Operating system: VPS on Ubuntu 20

Something I forgot to mention:

I’ve tried adding a workflow timeout in its settings, but that didn’t change behavior…

I also found this issue on github that could be related?

Hi, welcome to the community! I am very sorry for the trouble.

In a first step, can you try upgrading to n8n 1.15.1 or later? This version should include a fix for the problem you are seeing: fix(core): Prevent executions from becoming forever running by netroy · Pull Request #7569 · n8n-io/n8n · GitHub

Please do let me know if you’re still seeing “endless” executions afterwards.

1 Like

Thanks for following up! I’ll do the upgrade asap and let you know if that resolves things.

Maybe interesting to note is that the webhook works. As in, the health check nicely returns a 200, so it’s functional. Just doesn’t stop.

1 Like

Glad to hear the webhook itself still works!

I think the problem here (as with similar cases reported recently) is that the final execution status isn’t written to the database as it should be once the execution finishes. So the execution list fetches an execution with a start date, but no end date and no result from the database, and displays the execution as running. Let’s hope the update fixes the problem for you as well :crossed_fingers:

On a completely separate note, n8n also has a built-in health check endpoint these days at /healthz. So you might no longer need this extra workflow just to check whether n8n is alive. Of course it could make sense to keep the workflow as part of your end-to-end testing approach and to discover issues like this one.

Thanks for sharing some details, interesting! I had a hunch it was just the UI that was confused.

I have 1.15.2 up and running and will let you know how things go either way. I’ll keep my healthcheck workflow running at least to see how it’s doing, but great to hear there’s a built-in option for that now.
I noticed there’s also a metrics endpoint. any way of securing that one? or using that data in a workflow? I actually like the webhooks having a uuid path, which gives some kind of security.

I can confirm that the stopping problem seems to be resolved with v1.15.2.

However, I found some other new issues:


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.