Binary only usable in the next workflow step

Dear community,

I have a problem with the SeaTable Node that I am responsible for. SeaTable is a so called No-Code Database. It looks a bit like Excel in a browser or if you know Airtable, wenn SeaTable is a self-hosted alternative to Airtable.

Describe the problem/error/question

This is a simple but working workflow:

  1. Create a row in SeaTable
  2. Get the binary (I just download a public available PDF)
  3. Upload the binary to the row I just created in step 1, the row must be there to upload.

This workflow works if I download the binary in step 2:

But it is not working, if I get the binary first.

What is the error message (if any)?

Error 1:

Leaving just “data” as the propery time does not work anymore. n8n tells me that ‘data’ is not available anymore.

Error 2:

Therefore I tried to change the expression, but no matter what I tried, it is not working. I can see the object in the “Property Name”


Is this a problem with the node or with n8n?

Please share your workflow

Sharing the workflow will not help because the SeaTable node was not updated yet. I use a newer version as “community node”.

Share the output returned by the last node

Information on your n8n setup

  • n8n version: 1.18.0
  • Database (default: SQLite): SQLite
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker
  • Operating system: Debian 12

Thanks and best regards

Here is the relevant code from the node:

I use getBinaryDataBuffer to get the the binary. Might this be the problem?

Best regards

Hey @christophdb,

Right now n8n is not able to reference a binary output from nodes back in the workflow. What you need to do in that cases is using the merge node. Then the binary is one of the inputs and the other input is the other stuff you want to do.

Btw: Even if you use community nodes, sometimes it might be helpful to paste the workflow code :wink:


1 Like

Thank you very much.
That was a fast and very helpful answer. In the future, I will provide my workflow.

Here is how I solved it finaly. I want to create the row after I download the file to get the “file_name” in the “row create” event.

Thanks a lot.

1 Like

Thanks. It’s working great. Just had to change to merge instead of multiplex. Multiplex would create 9 items when I only had three to beginn with and the upload the first file three times.

1 Like

This topic was automatically closed 7 hours after the last reply. New replies are no longer allowed.