Bubble does not recognize the n8n webhook API address

I have a server in a supermarket that has an N8N installed on it. Basically it works like this:

The bubble sends a get to an n8n webhook api with a parameter called query that inside it has a query for a database from that supermarket.

n8n receives this get, takes the query and searches directly in their postgresql database, takes the result and does a respond to webhook to show all the information that was searched in the database in the result when I do the get in the bubble.

But I have a problem, they have a firewall on their network, that is, it doesn’t recognize anything that is coming internally, for example if I test it inside the supermarket with their network through postman, I can get it safely. But if I test using bubble it doesn’t even recognize the API IP.

Would anyone have a solution for supermarket staff to do but that isn’t too risky for their safety?

:information_source: I saw about localtunnel ngrok but I don’t know how it works, if they are the solution tell me here!!

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hey @Enzo_Carmo,

This sounds like a network routing issue, You will need to make sure you either open the port to allow the connection in or use something like ngrok / cloudflare tunnels. Before you attempt these though I would recommend you fully understand the risks associated with what you are doing, I would imagine the supermarket might have a network or IT team that may be able to assist with this.