[BUG] Baserow does not return empty value

image

There were supposed to be 44 empty items

Share the output returned by the last node

Information on your n8n setup

  • **n8n version:1.21.1
  • **Database (default: SQLite):postgres
  • Running n8n via (Docker):
  • **Operating system:Linux 20.04

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hey @Ruan17,

Looking at the description for that field it looks to be working as expected.

If active, will output a single, empty item when the output would have been empty. Use to prevent the workflow finishing on this node.

I guess what you were after was 44 empty items so maybe keeping the same amount of output items as the input even if the output may normally be a lot more or less items?

1 Like

I’m looking for 44 items, if there aren’t any, 44 empty items were supposed to come

Hey @Ruan17,

I will add a product idea for that, At the moment the option you are using is working as documented and as expected.

I guess the tricky bit is if your first call returns 100 items and the others return nothing would you then want 143 items returned so one empty item for each input just added to the output?