[BUG]: Broken loop?

Hi,
It was found that the loop function did not work; only the first item comes out of the SplitInBatches brick. To be sure, a workflow provided by n8n itself was used to check if this problem was reflected anywhere else (https://n8n.io/workflows/687) and unfortunately, it is.
Is this a bug ?
Best regards,
Audrey

Hey @Audrey_Terrien,

Welcome to the community :cake:

Do you have an example? I have just given the worklfow you linked to a go and it has worked and ran the loop twice and shows the 2 executions at the top of the of the RSS node with 10 items for the first URL and 12 for the second.

image

It is worth noting that in the UI you won’t see all of the items in the input boxes so in this worklow the URL will always show the last one that was ran.

Hi again @jon ! Thanks, happy to be part of the community :).

Well, I tried it again but this time by clicking on the execute workflow at the buttom and It work ! However, is it possible to have it work without having to click on the general buttom but on the last node ?

Audrey

Hey @Audrey_Terrien,

What do mean? Like have it run the entire loop process if you just wanted to check one node?