[Bug] Cannot connect Kafka Cluster

I try to use n8n cloud. Select Kafka node. Set Kafka Credentials (Confluent Kafka Cluster).
However, cannot connect to Kafka Cluster.

Prediction: As I know Confluent Kafka Cluster are using TLS. Kafka Credentials of n8n does not support TLS.

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hi @pdt590

Welcome to the community!

If they are using TLS you probably need to turn of SSL.
Atleast that is what is the case often with these kinds of connections.

@BramKn
Thank you. Kindly check my picture. I enabled SSL. it does not work.

I tried to use external Kafka Connector (Not belong to n8n). It works when I enable TLS.

Kindly read what I said. Turn it off :upside_down_face:

@BramKn Cannot fix it

Thanks for checking.
It says it is timing out. Which can be a lot of things.
Are you sure the n8n server has access to the cluster?

I am not familiar with Kafka or the confluent cluster. So we would need to wait for someone else to have a look :slight_smile:

I am using n8n Cloud. I tried on Node-Red and it worked to connect to confluent

image

Any Helps? Thanks