[BUG] Ghost Node UI Issue

Describe the problem/error/question

The Ghost Node in the UI only shows me two possible actions, “Get a Post” and “Get Many Posts.” However, the docs show multiple additional functions, including the one I need, “Create a Post.”

I was able to copy and paste the sample workflow for Ghost that included the “Create a Post” Node into my own workflow and use it without issue.

I’m able to make everything work as is, it seems like the problem is just that the Node is not being delivered via the Workflow menu.

This earlier post describes the same problem. The additional information I can provide is that I am definitely using the Admin credential type, but the problem persists. I do not need follow-up, I just wanted to flag the issue as still live for you. Hope this helps.

Information on your n8n setup

  • n8n version: 1.11.1
  • Database (default: SQLite): SQLite
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker/Digital Ocean
  • Operating system: Ubuntu 22.04.3 LTS

Hi @shalalalaw :wave: Looking at this - it looks like you may need to reconnect or re-add your credentials if you’re sure you have the admin type of credential set, as these should appear in the node:

Meanwhile, without the admin credential, you’ll see this as you describe:

1 Like

Thanks @EmeraldHerald I was able to verify that my credentials were, in fact, admin credentials. They worked when I used my workaround, and I was able to establish a connection via the retry button.

I just tried creating a new set of admin credentials, which, again, connected, but I still had the same problem where I only had access to the Get Post(s) node actions.

Not sure what’s up, but feel free to let me know how I can help.

Hi @shalalalaw Did refresh solve your issue? Was facing a similar issue it works well now.

1 Like

Hi @shalalalaw - to also piggyback off of @mcnaveen 's question and to just verify - you’re selecting this option, right? Just want to make sure!

@mcnaveen that’s what I tried first. I just tried again, and it didn’t fix the issue.

@EmeraldHerald Positive. I even tried deleting my content api account to see if that was the issue.

Hey @shalalalaw,

Out of interest did you open the node to then see if the options were available? They probably won’t show in the search box as that only shows the default credential options.

I have just very quickly tried this on my local install and it appear to be working for me.

As expected though they don’t show in the search list you need to open the node and select the operation that way.


Hey Jon, thanks for the response. I didn’t realize that not providing the ghost admin node in the sidebar was expected behavior! In that case, this is working as expected.

Hey @shalalalaw,

It is something we should look at changing but at the moment due to how the node is created it is “expected”, I take it then that your issue was not that the node wasn’t showing the options but that they didn’t appear in search?

It actually was both, including the issue with the node itself, but that resolved after taking some of the above steps.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.