Bug? Google geocode API giving error with special characters

Describe the issue/error/question

Not sure if this is a bug or was not developed. When running the Google Geocode API, I see that in n8n is not possible special characters (E.g. Sídney with the “í”), with a regular “i” works fine.

FAILS: https://maps.googleapis.com/maps/api/geocode/json?address=**Sídney** NSW, Australia
PASSES: https://maps.googleapis.com/maps/api/geocode/json?address=**Sidney** NSW, Australia

it works fine. But running same in POSTMAN runs ok. Is it possible to make this in a way that it will also run with the special characters? Thank you very much.

What is the error message (if any)


Information on your n8n setup

  • n8n version: 0.201.0
  • Running n8n via [Docker]:

Hi @Jorge_M, I am sorry you are having trouble.

Based on your description I am unfortunately not sure what exactly you are doing. Could you share the workflow leading to the error you have described?

Also, can you confirm if the problem also persists with the current version of n8n?

Hi @MutedJam ,
I was using version 0.201.0, but also the most recent has same error, and it is creating non-UTF errors

400 - “{\n "error_message" : "Invalid request. One of the input parameters contains a non-UTF-8 string.",\n "results" : [],\n "status" : "INVALID_REQUEST"\n}\n”

Basically by using “í” and not “i” in the POST request body, so non-UTF strings, it always creates an error. But as I was mentioned, it still works properly if I make same requests using POSTMAN. It is ok in general, but in cases like German, Turkish, Polish strings, the HTTP request will always throw an error. Thank you.

Hi @Jorge_M, can you try using the query parameters option of the HTTP Request node to submit your values? This option accounts for the encoding when I tested this just now. Like so:


1 Like

Thank you very much @MutedJam , it works fine :).

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.