Bug in Wait node

whatever wait time I enter, it always gets schedule till 5hrs+ entered time.
I’m not sure where this bug is coming from.

hello @Jackson_beno

If you specify a wait time of more than 65 seconds, then the workflow will be offloaded and run in the background. The scheduled time may not be very accurate, as it depends on the server’s time, that is by default GMT-5


Changing to GMT +0 in workflow settings resolved this issue.

I’ll still call it a bug because the clearly says wait for certain sec and not a certain time with respect to GMT.