trigger is not working

Hi guys! I’m trying to create → Notion workflow, but trigger doesn’t work for some reason. However, it does create a webhook (I’ve noticed it in settings). I’ve tried to tweak in many ways, but still didn’t manage to make it work. Real booking, test ping — nothing works.

Information on your n8n setup

  • n8n version: 0.224.4
  • Database (default: SQLite): PostgreSQL
  • n8n EXECUTIONS_PROCESS setting (default: own, main): not sure what it means
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Railway
  • Operating system: Windows 11

Hey @Georgy,

Is the webhook url correct?

Yeah, I’ve used Cal trigger, so it creates a webhook automatically in settings (I saw it in the “Webhooks” section), but even when I created a webhook myself and tested in with a “Ping test” feature on, it still didn’t work.

Does the webhook url work if you manually try testing it with something like curl?

Is the url that is registered the test one or the production one? Before doing the test ping are you clicking on execute workflow?

Does Railway log any incoming connections, it is not something I am familiar with.

Sorry, I’m quite a newbie in automation and n8n — what’s “curl”?

I’ve tried both test and production ones. I did try activating the workflow too.

As for Railway logs: well, I’m not 100% sure, but it seems that it has logs only for Postgres, though they don’t look particularly useful in this case.


One of the users from n8n Telegram group reached out to me and tried to help me — which he did, but not quite yet.

He sent me the link to the guide (Hosting n8n for Free with Railway) which mentioned that I need to set up specific variables in Railway n8n configuration — I didn’t know about that. Basically, as far as I understand, n8n used localhost instead of a proper URL.

That being said, I followed the steps in the guide, and it seems like I’m gonna use a proper URL now. I suppose it was just localhost before since this is what I saw in webhooks.


But I encountered another error:

Problem running workflow

UNKNOWN ERROR - check the detailed error for more information

Show Details

Cal Trigger: Request failed with status code 400


Not sure how to fix it now, but gonna try — I’ll appreciate any help!

Update 1:

I cannot activate workflow either.


OK, so I finally found the solution — it wasn’t related to n8n, but Railway n8n configuration.

Huge thanks to @serg for the help :sparkling_heart:

So here’s what I did and how I fixed it in the end:

  1. Installed n8n in Railway from the starters.

  2. Deployed it successfully.

  3. Connected my own domain.

  4. Opened n8n and created an account.

  5. Created a workflow — with Cal and Notion triggers.

  6. Failed and made a post on this forum (here’s where the actual guide starts).

  7. @serg contacted me on Telegram and offered to help.

  8. Followed the guide by Alex Hyett and created new variables in Railway n8n configuration.

  1. Created new credentials because I made a new encryption key (N8N_ENCRYPTION_KEY).

  2. Noticed a proper webhook URL in the Cal trigger, but got error 400 instead.

  3. @serg suggested that it might be an HTTPS issue, since he did have it in the webhook URL.

  4. Indeed, I did add a production URL for n8n Railway, but without HTTPS — fixed it by simply adding HTTPS to the URL.

  5. Tried to test Cal trigger again — success, it works now, yay!


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.