Calendly webhooks don't fire if workflow is created via N8N API?

Describe the problem/error/question

I have an onboarding process which automatically creates a workflow to listen for calendly meetings. I’ve set up the workflow manually before and confirmed it works properly.

Now, when I create a workflow manually and copy/paste my predefined workflow, set up a new calendly node and attach the credentials (created via API) the workflow fires like expected when meetings are being booked via calendly.

However, when this same workflow is created via the API and activated the webhook does not fire when calendly meetings are being booked. If I replace the calendly node manually it still doesn’t work. If I copy/paste the entire workflow into a new workflow and set up a new calendly node with the same credential… it does work. Not sure where to begin troubleshooting with this one…

What is the error message (if any)?

No error message, meetings booked just don’t trigger executions

Please share your workflow - THIS ONE WORKS

Please share your workflow - THIS ONE DOESN’T WORK

Information on your n8n setup

  • n8n version:1.21.1
  • Running n8n via n8n cloud
  • Default rest

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

@Jon maybe you’ve got a clue here?

hello @revhuntr

Your second workflow does not contain the WebhookId, that’s why it doesn’t work.

While we display that value in the workflow preview you could be onto something…

If the node has been duplicated it could be causing an issue so with webhook triggers it is always best to add a new one instead of making a copy.

@Jon Thanks for the reply. I have refactored and isolated the problem now.

I create this workflow via the N8N API, where the calendly trigger does not fire when meetings are created on calendly:

In order to get it working I delete the Calendly node and set it up manually. I use the credentials which were programmatically created. This workflow then works properly:

This is how I create the workflow, just pasting the N8N node:

So something seems to be up with how the workflow is created and specifically how the calendly trigger is configured (or a deeper bug) in the N8N API node.

For clarity, this is how the calendly node is being configured in the N8N API Node call:

            "parameters": {
                "scope": "organization",
                "events": [
            "name": "Calendly Trigger",
            "type": "n8n-nodes-base.calendlyTrigger",
            "typeVersion": 1,
            "position": [
            "credentials": {
                "calendlyApi": {
                    "id": "{{ $json['id'] }}",
                    "name": "{{ $json['name'] }}"

Any suggestions or advice would be welcome

Can you be more specific on how you manually set it up? Is this from inside Calendly or in n8n?

I will test the node again but last time I tried it was working as expected, I suspect there could be an issue with the check and maybe the id is already in use.