Can’t activate workflow with Github Trigger

Describe the issue/error/question

Can’t activate workflow with Github Trigger. After click “Active” then there is an error

What is the error message (if any)?

Workflow could not be activated:
UNKNOWN ERROR - check the detailed error for more information
Github Trigger: Not Found

Information on your n8n setup

  • n8n version 0.185.0
  • Running n8n via: Docker

Hi @irekrog, welcome to the community!

I am sorry to hear you’re having trouble. The GitHub trigger works by registering a webhook for your repository. If you don’t have admin privileges for the repository, GitHub might return a “Not Found” error which seems to be what has happened here.

Can you confirm if you’re the owner of the repo you’re trying to activate the trigger for?

Yep, I am creator of this repo

Hi @MutedJam , any ideas what could I do wrong?

Hi @irekrog, I am afraid not. Did you set a non-standard URL in your GitHub credentials by any chance?


Nope, I created a workflow in n8n and when I manually execute a workflow then a trigger listening on the new star, after clicked a star in repo I get response in Github Trigger so manually it works. But I can’t activate workflow to listening all the time… Yesterday I tried with different workflows, different repos, with Access Token and OAuth2 and still have same error :open_mouth:

Can you confirm if your webhook URL is publicly accessible? You can view it after clicking “Webhook URLs” like so:


If your URL says localhost GitHub wouldn’t be able to send data to it and you might need to set the WEBHOOK_URL environment variable.

Test URL:
Prod URL:

Thank you so much for confirming @irekrog. I was able to reproduce the problem and have added this to our internal bug tracker for a closer look.

In the meantime you should be able to manually work around the problem by setting up a Webhook node (make sure to set the method to POST) and then manually registering the Webhook with GitHub on the settings page of your repository:

Please accept my apologies for the inconvenience this causes.

1 Like

Hi, thank you for your help! It works fine with workaround! :tada:

And no problem I hope this issue will be fixed :slight_smile:

1 Like