Can’t import any workflow from to my self-hosted license

Hey people!

Could you please help me how can I import a workflow from n8n workflow templates to my self-hosted plan? Particularly, I need this one: Back Up Your n8n Workflows To Github | n8n workflow template to set up an automatic backup of my workflows to GitHub.

I tried it via Community Nodes, but could not find this workflow at keywords:n8n-community-node-package - npm search

I also tried to import a workflow via URL, but got an error “Invalid URL”, see screenshots for this.

Also I checked here in the forum, found only one answer: Backup self hosted n8n workflows to git
And this seems not properly working too, if you read the comments.

Looking forward to your help + thanks a lot!

Mike from Berlin

Information on your n8n setup

  • n8n version: 1.8.2
  • Running n8n via Docker
  • Operating system: Mac OS

Hey @mmueller,

Welcome to the community :cake:

The quickest option is to select the nodes in the workflow and do a copy / paste into a new workflow on your own instance. Another option you could try is on the left of your n8n instance click on Templates which will show you the same list and you can click on the workflow and select “Use this workflow” on the top right and it will import it so you can use ti.

1 Like

Thanks dear @Jon, it works!!! :star2::star2::star2::star2::star2:

One question though @Jon :
On the website I see this workflow: Back Up Your n8n Workflows To Github | n8n workflow template and in the n8n self-hosted app it is another workflow, where I cant get what to fill out in the actions with “!”. Could you please help me with it?

Hey @mmueller,

That workflow should exist in the app as well both the website and the app load the workflows from the same source. If you look at the list of templates in the app it should be about 4 or 5 down without needing to type anything.

1 Like

Thank you @Jon !

It worked with the workflow “Git backup of workflows and credentials”. But - I get an error:

Could you maybe send a link with explanation what exactly must be inserted here to connect to Git?

Hey @mmueller,

That looks like a different template, You would need to open the open the node to see what it thinks the issue is but it looks like you don’t have a git repo in the folder it is using.

That workflow template was submitted by a community member 2 years ago, But it looks like it has some set up steps to follow in the description which you can find here: Git backup of workflows and credentials | n8n workflow template

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.