Cannot access node output prior to Dropbox create folder node

Describe the problem/error/question

I am trying to create folders and subfolders for each month of the year. Dropbox’s “Create Folder” action throws an error if the folder already exists, so I’m trying to list the folder and then create it if there’s an error.

What is the error message (if any)?

The output of nodes prior to the dropbox list folder node is lost.

I know some modules break the link between input and output if there isn’t a clear matchup, but this should be a very clear one input to one or more outputs.

I thought the connection might be getting lost because all of the rows I care about come from “Continue on fail” situations. But I get the same problem if I connect the create folder node to the false output of the IF node.


Please share your workflow

Share the output returned by the last node

Information on your n8n setup

  • n8n version: 1.9.3
  • Database (default: SQLite): Postgres
  • n8n EXECUTIONS_PROCESS setting (default: own, main): queue mode
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker/Amazon ECS
  • Operating system: Alpine Linux / Docker container based on n8nio/base

Hi @Lee_S :wave:

I got this working by changing the last node to expect {{ $('Full Folder Path').item.json.Folder }} - so taking your workflow, doing this:

That created the folders as expected :slight_smile:

I tried that. At least on the items that had the “error” element set, there was no .item within $(‘Full Folder Path’). I tried to illustrate that in my post in one of the screenshots above - when I enter {{ $(‘Full Folder Path’) }} the object is empty - you see Object: [{}] in the screenshot. When I entered {{ $(‘Full Folder Path’).item }} it gave me some kind of evaluation error that I didn’t screenshot.

I worked around this by just creating the folders and ignoring the error message when the folder already exists. But the bigger question - and one I find myself asking in a lot of N8N scenarios - is “why does the connection with upstream data get lost past this module?” In this case it shouldn’t be happening (as your fix shows) but it was happening for me and very confusing.

Happy to help dig into this and figure out why I was seeing what I was seeing and whether that’s the correct behavior or not.

Lee

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.