Cannot access some workflows since n8n update

Describe the issue/error/question

I have just updated my n8n version to 1.6.0. Since the update I can’t load some workflows (6/14)

What is the error message (if any)?

No error message, the workflow is just not loading.

Please share the workflow

(Select the nodes and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow respectively)

Share the output returned by the last node

Information on your n8n setup

  • **n8n version:1.6.0
  • Database you’re using (default: SQLite):
  • Running n8n with the execution process [own(default), main]:
  • **Running n8n via [Docker, npm, n8n.cloud, desktop app]:desktop app

Hey @jeremydahan,

Welcome to the community :cookie:

Normally when a workflow fails to load it will show a little message in the bottom right, What version did you update from and if you go back to the old version does it still work?

Hi @jon
Thank you for your answer.

Normally when a workflow fails to load it will show a little message in the bottom right
→ Surprisingly no little message in the bottom right. Just nothing

What version did you update from and if you go back to the old version does it still work?
→ I can’t remember the version but when I had both on my Mac worflows did load with the older version. If I remembered well, when both version where installed, workflow that do not load today, did load when both version were opened.
That is why I uninstalled the older version. I thought It would continu to load correctly

Also, I tried launching workflows that do not load through my CLIand It worked.

Hey @jeremydahan,

That is very odd, When you say through your CLI what do you mean? Are you running both Desktop and npm versions of n8n?

Yes for npm version
Can I access previous version of n8n desktop app to test ?

That is a good question I am not sure if we archive them anywhere. Is there a chance that you used the npm version of n8n with User Management installed then went back to the desktop app before upgrading at any point over the last couple of months?

Yes, totally. Never done anything about user management on desktop app :s

There is an odd issue I am aware of where if you had loaded a newer install on the older database then went back to an older version to make workflows those workflows wouldn’t be available to the user and the same with credentials.

If you can access it from the NPM version what I would do as a quick solution would be to make the workflows again with some copy / pasting that should sort the issue out. The other option would be to edit the database if you have any sqlite tools installed.

I checked the consol and when I clicked here the message that arrive on console

Yes ok I see. I will try with an sqlite tools
If I go for the quick solution, How can I delete the workflow that doesn’t load so they don’t display on my list of workflow (in order to be clean) ?

So what you would have to do is make the new workflow from the npm version and delete the old one as well then you should be good from Desktop.

Hi @jon,
Thank you for all of your answers.
What command do you use to delete a workflow using CLI ? (cannot delete from desktop version)

Hi @jeremydahan,

I don’t know if you can from CLI, I would do it in the UI or with the API.