Cannot create WordPress post

Describe the problem/error/question

I’m using the basic Telegram bot feature. My goal is that if the answer is correct, it should create a post in my WordPress Blog:

WordPress configuration:

What is the error message (if any)?

However, I noticed two errors:

  1. When I configure the credentials, I get: “Couldn’t connect with these settings More details”

I tried to create 3 credentials without success. I created them based on the documentation:

  1. When I try to run the bot:

Please share your workflow

This is the WordPress failing part:

{
“meta”: {
“templateId”: “2035”,
“templateCredsSetupCompleted”: true,
“instanceId”: “6a22b654530ee8e0e3f17f611c73b11ff6b32ebc6b0a196bc6fb3795887d4e63”
},
“nodes”: ,
“connections”: {},
“pinData”: {}
}

Share the output returned by the last node

Stack

NodeApiError: The resource you are requesting could not be found
    at Object.requestWithAuthentication (/usr/local/lib/node_modules/n8n/node_modules/n8n-core/dist/NodeExecuteFunctions.js:1187:19)
    at processTicksAndRejections (node:internal/process/task_queues:95:5)
    at Object.requestWithAuthentication (/usr/local/lib/node_modules/n8n/node_modules/n8n-core/dist/NodeExecuteFunctions.js:1876:20)
    at Object.wordpressApiRequest (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/Wordpress/GenericFunctions.js:26:16)
    at Object.execute (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/Wordpress/Wordpress.node.js:149:40)
    at Workflow.runNode (/usr/local/lib/node_modules/n8n/node_modules/n8n-workflow/dist/Workflow.js:700:19)
    at /usr/local/lib/node_modules/n8n/node_modules/n8n-core/dist/WorkflowExecute.js:656:53
    at /usr/local/lib/node_modules/n8n/node_modules/n8n-core/dist/WorkflowExecute.js:1058:20

Information on your n8n setup

I’m using the cloud one.

Any idea what I’m doing wrong? Thanks.

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

It’s the cloud edition. I haven’t deployed it on my local or anything.

Hey @fanmixco,

Welcome to the community :cake:

If the credential test is failing I would expect it all to fail, Can you share what URL you are using in the Wordpress credential? It may also be possible that a wordpress plugin is blocking access to the API.

Hi @Jon, thanks for your reply. I have tried two:

https://fanmixco.wordpress.com => Old one
https://fedenavarretea62f0e866f3.wordpress.com => Recently created

Hey @fanmixco,

What version of Wordpress are you using and which plugins do you have enabled?

Hi @Jon, I don’t have any plugins. Should I have any? About the version, I’m using the one provided by wordpress.com, I don’t have it in any hosting or public or private cloud. I’m just trying to test the plugin. I know it’s something related to WordPress since I was able to Tweet in X.

I am not allowed to install plugins:

Hey @fanmixco,

I will need to set up a wordpress.com account to test with but they could be doing something different with the authentication to wordpress itself which would change things.

1 Like